Author Topic: Issues thread  (Read 12099 times)

0 Members and 1 Guest are viewing this topic.

Online MartyS (Gromit)

  • Compsognathus
  • *****
  • Posts: 10025
  • Liked:
  • Weirdies!
    • My homepage
Issues thread
« on: April 07, 2011, 10:50:51 AM »
Very minor thing: a Riff volume of 50 is kind of loud compared to the movie, so when it cuts in it can be a bit jarring. Perhaps adding a line with the default riff volume in the ".sync" file would be a good idea? Just a thought.

Also, is there a way to show the movie time? It's a bit difficult to find specific spots in the movie without it. Also, a slider bar to movie around in the movie would be nice.

It would be nice to have a way for the player to remember the riff and movie volume settings, it can take a while to get just the right mix.  Mplayer does try to save volume settings for the move, and usually when you put a disk in that you already played it does remember it, maybe that code could be exploited.

For a time display go to "options" "OSD".

I asked about the slider bar during alpha testing and was told it might not be possible.  Once you get used to the keyboard shortcuts for time jumping it's pretty easy to move around.  Up/Down arrows are one minute, Right/Left arrows 10 seconds, PageUp/PageDown buttons are 10 minute jumps.
« Last Edit: February 25, 2012, 03:54:33 PM by MartyS (Gromit) »


Offline ReiCow

  • Riffplayer Developer
  • Schnappi Supporter
  • ***
  • Posts: 117
  • Liked:
Re: Issues thread
« Reply #1 on: April 07, 2011, 01:12:19 PM »
Saving the volumes is on the todo list.

Cheers,
ReiCow


Offline fireyf

  • Big Montana
  • *****
  • Posts: 962
  • Liked:
  • Humans are superior!
Re: Issues thread
« Reply #2 on: April 07, 2011, 08:03:58 PM »
I'm trying to make a sync file for a iriff I made.  I thought the riff syncs to the movie just fine but when I skip ahead in the riff player the riffs are coming in late.  Could this be an issue with this particular DVD in that it just doesn't stay synced if you skip?  The riff is for The Wizard.  If anyone here has bought it and it doesn't sync right (meaning I screwed up royal) please let me know.  Otherwise I'm just wondering if I just can't go skipping with some movies.


Offline ReiCow

  • Riffplayer Developer
  • Schnappi Supporter
  • ***
  • Posts: 117
  • Liked:
Re: Issues thread
« Reply #3 on: April 08, 2011, 12:00:38 AM »
The riff file has three numbers:

riffdelay_init=107.00
riffstart=13.000
time_offset=1.0010090000000

riffdelay_init is the offset value of the mp3 time and the dvd time (roughly)
riffstart is when (IN DVD TIME) the riff shoudl start playing
time_offset is a time multiplier for how the dvd time grows (it does nto grow at the same rate as the mp3 time).

If you make a sync file that starts at the right time and is linked up during play.. but desyncs when you skip around.. your time_offset is wrong.

Cheers,
RC


Doctor Who?

  • Guest
Re: Issues thread
« Reply #4 on: April 08, 2011, 05:35:28 PM »
I don't know if this is the place to report this kind of issue but i just thought i would let you guys know that when playing the Star wars episode 1 riff the riff seems to be about 2 or 3 seconds behind the movie.

Just thought i would let you guys know.

Other wise this new player seems great and it is easier to use then the old one.

great job!


Offline fireyf

  • Big Montana
  • *****
  • Posts: 962
  • Liked:
  • Humans are superior!
Re: Issues thread
« Reply #5 on: April 09, 2011, 07:07:12 PM »
The riff file has three numbers:

riffdelay_init=107.00
riffstart=13.000
time_offset=1.0010090000000

riffdelay_init is the offset value of the mp3 time and the dvd time (roughly)
riffstart is when (IN DVD TIME) the riff shoudl start playing
time_offset is a time multiplier for how the dvd time grows (it does nto grow at the same rate as the mp3 time).

If you make a sync file that starts at the right time and is linked up during play.. but desyncs when you skip around.. your time_offset is wrong.

Cheers,
RC
Thanks.  I think I may have it working now.  Need to do a few more tests to be sure.


Offline Nunyerbiz

  • Mayor of Nilbog
  • *****
  • Posts: 3390
  • Liked:
Re: Issues thread
« Reply #6 on: April 11, 2011, 05:06:00 PM »
I noticed on the "help us test the player" post in the Announcements board, the movie Twilight was listed as being one of the .sync files that was available for testing. When I looked under the current .sync files available for download, I see Eclipse but not the first Twilight. Is one of these a typo? Or was the "test" version of the Twilight .sync file deemed not ready for prime time?

Also, the FAQ link in the initial post is dead, just returns a 404.


Offline torgosPizza

  • Administrator
  • *****
  • Posts: 7721
  • Liked:
  • Heaven is nowhere, just look to the stars.
    • RiffTrax
Re: Issues thread
« Reply #7 on: April 12, 2011, 02:21:41 PM »
Yes, Twilight that was made for the initial Alpha release will not work with the current player.

Not sure where the FAQ should be going but it doesn't matter since that was for testers. I think. I'll check but I'm pretty sure it's of no matter.


Offline Nunyerbiz

  • Mayor of Nilbog
  • *****
  • Posts: 3390
  • Liked:
Re: Issues thread
« Reply #8 on: April 13, 2011, 01:53:33 AM »
Just poked around the player page, the FAQ appears valid. I think you have an extra character in your link at the start of this thread.

http://www.rifftrax.com/playerfaq



Offline torgosPizza

  • Administrator
  • *****
  • Posts: 7721
  • Liked:
  • Heaven is nowhere, just look to the stars.
    • RiffTrax
Re: Issues thread
« Reply #9 on: April 13, 2011, 06:28:56 PM »
Ah yes, weird. Fixed. Thanks!


Watchman

  • Guest
Re: Issues thread
« Reply #10 on: April 20, 2011, 01:45:17 AM »
FYI, regarding The Wrath of Khan, the Riffplayer worked better for me with the Director's Edition than the Theatrical Cut. With the latter, my experience was that the riffing was coming half or 1 second too early, so the jokes came before the characters finished their sentences. But the Director's Edition worked perfectly in the Riffplayer.


Offline ReiCow

  • Riffplayer Developer
  • Schnappi Supporter
  • ***
  • Posts: 117
  • Liked:
Re: Issues thread
« Reply #11 on: April 26, 2011, 05:46:29 AM »
The Khan timings are made with the current version of the player (0.4.3), which changed timing slightly.

Cheers,
ReiCow


Offline CJones

  • The FBI Pays Me to Surf
  • *
  • Posts: 2852
  • Liked:
Re: Issues thread
« Reply #12 on: May 20, 2011, 04:20:37 PM »
The Pirates of the Caribbean sync file is spelled wrong. Should be two 'b's and one 'r', not the other way around. Just letting you know.

Also, as long as I'm here, it seems like every time I go into the audio options (such as to adjust the equalizer) the riff stops playing, but the movie goes on, and the only way I see to get it started again is to restart the whole thing. And speaking of which, I'd really like it if the max volume levels could be increased (which is why I'm messing with the audio options to begin with). Ever since I got my new Win 7 computer, it seems like I can't make anything loud enough unless I'm using VLC (which allows up to 200% volume, by default), which is what I typically use to watch movies and riffs.

And finally, a suggestion: Have the player re-sync automatically after every pause. Or at least have that as an option. I just got done watching Birdemic, and I found that after any pause of any significant length (I'm guessing this means any where the disc stops spinning), I had to hit re-sync or it would be noticeably off.


Offline ReiCow

  • Riffplayer Developer
  • Schnappi Supporter
  • ***
  • Posts: 117
  • Liked:
Re: Issues thread
« Reply #13 on: May 23, 2011, 09:10:15 AM »
The riff doesn't actually stop.. the volume simply goes to zero. You can just turn the volume back up. This is a known issue.

As for the riffsync after pause.. do you have 0.4.3? (The latest version.) I ask because the player DOES resync after play resumes after pause.

Cheers,
RC

The Pirates of the Caribbean sync file is spelled wrong. Should be two 'b's and one 'r', not the other way around. Just letting you know.

Also, as long as I'm here, it seems like every time I go into the audio options (such as to adjust the equalizer) the riff stops playing, but the movie goes on, and the only way I see to get it started again is to restart the whole thing. And speaking of which, I'd really like it if the max volume levels could be increased (which is why I'm messing with the audio options to begin with). Ever since I got my new Win 7 computer, it seems like I can't make anything loud enough unless I'm using VLC (which allows up to 200% volume, by default), which is what I typically use to watch movies and riffs.

And finally, a suggestion: Have the player re-sync automatically after every pause. Or at least have that as an option. I just got done watching Birdemic, and I found that after any pause of any significant length (I'm guessing this means any where the disc stops spinning), I had to hit re-sync or it would be noticeably off.


Offline CJones

  • The FBI Pays Me to Surf
  • *
  • Posts: 2852
  • Liked:
Re: Issues thread
« Reply #14 on: May 24, 2011, 04:39:47 PM »
The riff doesn't actually stop.. the volume simply goes to zero. You can just turn the volume back up. This is a known issue.

Thanks for that. I see the slider for the riff volume doesn't actually drop to zero, but as soon as I try to move it the riff comes back on. That'll save me a lot of restarts.

Quote
As for the riffsync after pause.. do you have 0.4.3? (The latest version.) I ask because the player DOES resync after play resumes after pause.

Yes, I was using 0.4.3

The Pirates of the Caribbean sync file is spelled wrong. Should be two 'b's and one 'r', not the other way around. Just letting you know.

Also, as long as I'm here, it seems like every time I go into the audio options (such as to adjust the equalizer) the riff stops playing, but the movie goes on, and the only way I see to get it started again is to restart the whole thing. And speaking of which, I'd really like it if the max volume levels could be increased (which is why I'm messing with the audio options to begin with). Ever since I got my new Win 7 computer, it seems like I can't make anything loud enough unless I'm using VLC (which allows up to 200% volume, by default), which is what I typically use to watch movies and riffs.

And finally, a suggestion: Have the player re-sync automatically after every pause. Or at least have that as an option. I just got done watching Birdemic, and I found that after any pause of any significant length (I'm guessing this means any where the disc stops spinning), I had to hit re-sync or it would be noticeably off.