Author Topic: Frequent error messages when trying to load RiffTrax Player  (Read 2218 times)

0 Members and 1 Guest are viewing this topic.

Offline Thenightgaunt

  • Disembaudio's Squadio
  • *
  • Posts: 8
  • Liked: 0
Frequent error messages when trying to load RiffTrax Player
« on: October 24, 2009, 11:01:39 PM »
I posted this on the "If the RiffTrax DVD Player doesn't work for you... read this" thread but just in case I thought I'd give it it's own thread.

I am having a problem that I noted was mentioned here. In the past the player has worked fine, though I haven't used it in a few months. Recently it began experiencing errors. I uninstalled the program, DL'd the newest version, and reinstalled. Still errors. Repeat the process, still errors. At the moment I am unable to get it to work at all.
So I thought I'd go through the errors step by step to aid in better diagnosis:

Upon starting up the program an error window appears after the "Rifftrax" logo vanishes

"Unsupported string encoding."

If I hit "Ok" the program loads (though it appears as "Not responding" in Task Manager), but rather slowly. Then another error message pops up.
"Access violation at address 007FC0BB in module 'RiffTrax.exe'. Read of address 00000000."

If I hit "Ok" again the player appears to open normally.

When I choose a RiffTrack to load another message pops up.
"Access violation at address 00BDE733 in module 'RiffTrax.exe'. Read of address 0000026C."

The program then slows down (window is solid white),and appears to be "not responding" in the task manager. Though under the "applications" tab there appear to be 2 rifftrax programs running. Under the processes tab there's only 1, "Rifftrax.exe"

If it does load, an error pops up saying
"The connection with the server was reset." and gives me the option to terminate the program. After "ok"ing the message it appears again and after "ok"ing that the "loading Rifftrax" screen appears and fills to 100%.

Then the error message
"Access violation at address 00BDE7DE in module 'RiffTrax.exe'. Read of address 00000284." and another offer to terminate the program.

If i hit "ok" again, the main window appears normal. The options on the Rifftrax Bar are colored/greyed out as though the rifftrax file were loaded. And the program no longer appears to be "not responding" in the task manager, instead it's "running". However, none of the buttons or menus in the window are functional or respond. Its as though it were only an image of the window.

If I hit the X in the top right corner to close the application this error pops up.
"Access violation at address 00BDD8EB in module 'RiffTrax.exe'. Read of address 000002E8."
Hit "ok", then it locks up again for a bit and finally gives me the message
"Access violation at address 00BE14C3 in module 'RiffTrax.exe'. Read of address 00000284."
Hit "ok" at which point the application closes, and a few seconds later gives the error.
"Cannot resolve the "rifftrax.com" MX record."

Now I load the program again and get these error messages popping up.
On program start up  "Missing element name."
And when loading a rifftrax file An exception was raised on the server: Access violation at address 004048B6 in module 'ComX.exe'. Read of address 000FAFE9.
and a minute after the program is closed Connection error: "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond"

I'm running Windows XP home edition. Fully up to date with Service Pack 3. With a 3ghz duo core processor, 2 gigs of ram and an NVIDIA Geforce 8800GTS card. I have the K-lite codec pack installed. I'm having no other problems with my system. These errors pop up dispite the .riff file I try to load or if I have a DVD in the drive or not. I've tried on old files that I know work and no good.
The only changes that have occured to my system since I last used the program were a nasty virus infestation that I cleared out (no problems everything in the green as it were) and I uninstalled McAfee and installed ESET in its place.
« Last Edit: October 26, 2009, 12:48:59 AM by Thenightgaunt »